周期串Uva455 紫书P57 3-4

A character string is said to have period k if it can be formed by concatenating one or more repetitions

of another string of length k. For example, the string ”abcabcabcabc” has period 3, since it is formed

by 4 repetitions of the string ”abc”. It also has periods 6 (two repetitions of ”abcabc”) and 12 (one

repetition of ”abcabcabcabc”).

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your

program will test followed by a blank line. Each test case will contain a single character string of up

to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are

separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

 

最开始以为是求出现次数最小的那个字符;

后来想一想不对;

然后看着数据不大, 就用暴力枚举的方法;

求出最小的周期,那么就是从最小的开始枚举,也就是长度为1, 再judge;

当然这道题也可以试着暴力模拟(标准的答案),但是我觉得太复杂了。

 

#include<bits/stdc++.h>
#define clr(x) memset(x, 0, sizeof(x))

#define LL long long

using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 100005;
char str[1005];
char s[1005];
int main()
{
    int T;
    cin >> T;
    while(T--)
    {
        clr(str);
        cin >> str;
        int len = strlen(str);
        for(int i = 0; i < len; i++)
        {
            if(len % (i+1) != 0)
                continue;
            int cnt = 0, flag = 1; clr(s);
            for(int j = 0; j <= i; j++ )
            {
                s[cnt++] = str[j];
            }
            //puts(s);
            int tmp = i + 1;
            for(int k = 0; k < len / (i + 1) - 1; k++)
            {
                for(int l = 0; l < cnt; l++)
                {
                    //printf("%c %c\n", s[l], str[tmp]);
                    if(s[l] != str[tmp++])
                    {
                    flag = 0;
                    break;
                    }
                }
            }
            if(flag)
            {
                cout << i + 1 << endl;
                if(T)
                cout << endl;
                break;
            }
            //puts("_________");
        }
    }
    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值