hduoj 3949: XOR(线性基)

XOR

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3388    Accepted Submission(s): 1158


Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.
 

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,......KQ.
 

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.
 

Sample Input
  
  
2 2 1 2 4 1 2 3 4 3 1 2 3 5 1 2 3 4 5
 

Sample Output
  
  
Case #1: 1 2 3 -1 Case #2: 0 1 2 3 -1


题意:

给你个n个数,这n个数总共可以构成2^n-1个集合(除掉空集)

每个集合的值为这个集合中所有数字的异或和,算出所有集合的值之后从小到大排序后并去重可以得到一个序列

接下来Q次询问,每次询问给你一个数K,求新序列中第K小的数

特殊的,如果K>序列元素个数,输出-1


线性基模板题

http://blog.csdn.net/jaihk662/article/details/78647156下面就有这道题题解

求出线性基后贪心即可,不过如何求出序列中有多少个数呢?(判断输出-1的情况)

如果线性基有k个元素,那么肯定可以构成2^k个不同值,也就是2^k个不同的数

不过空集不能算,所以应该是2^k-1个数

但是!如果k<n,说明原先n个数存在一个非空集满足异或为0,所以有

当k==n时,共有2^k-1个数

当k<n时,共有2^k个数


特判-1的情况后,就是模板了

#include<stdio.h>
#include<string.h>
#define LL long long
LL a[10005], p[66], jz[66];
int main(void)
{
	LL k, siz, ans;
	int T, n, i, j, cnt, Q, cas;
	scanf("%d", &T);
	cas = 1;
	while(T--)
	{
		scanf("%d", &n);
		for(i=1;i<=n;i++)
			scanf("%lld", &a[i]);
		memset(p, 0, sizeof(p));
		for(i=1;i<=n;i++)
		{
			for(j=62;j>=0;j--)
			{
				if(a[i]&(1ll<<j))
				{
					if(p[j]==0)
					{
						p[j] = a[i];
						break;
					}
					else
						a[i] ^= p[j];
				}
			}
		}
		for(i=62;i>=1;i--)
		{
			for(j=i-1;j>=0;j--)
			{
				if(p[i]&(1ll<<j))
					p[i] ^= p[j];
			}
		}
		cnt = 0;
		for(i=0;i<=62;i++)
		{
			if(p[i])
				jz[cnt++] = p[i];
		}
		siz = 1ll<<cnt;
		if(cnt==n)
			siz -= 1;
		scanf("%d", &Q);
		printf("Case #%d:\n", cas++);
		while(Q--)
		{
			scanf("%I64d", &k);
			if(k>siz)
				printf("-1\n");
			else
			{
				ans = 0;
				if(siz%2==0)
					k--;
				for(i=0;i<cnt;i++)
				{
					if(k&(1ll<<i))
						ans ^= jz[i];
				}
				printf("%I64d\n", ans);
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值