HDU 5858 Hard problem(几何)

20 篇文章 4 订阅

Hard problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 364    Accepted Submission(s): 271


Problem Description
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?


Give you the side length of the square L, you need to calculate the shaded area in the picture.

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
 

Input
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
 

Output
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
 

Sample Input
  
  
1 1
 

Sample Output
  
  
0.29


Source
推公式

以下AC代码:
#include<stdio.h>
#include<math.h>
double p=3.14159265358979323846;
int main()
{
    int t;
    double l;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&l);
        double c=(double)sqrt(2.0)*5*1.0/8.0;
        double angel=acos(c)*1.0/p*180.0;   ///小角度
        double anglen=2*angel;
        double sshanxing1=anglen*1.0*p*l*l/360;      ///小扇形
        double ssanjiao1=sqrt(7*1.0/32*1.0)*5*sqrt(2.0)*l*l*1.0/8.0;   ///大三角
        double s1=sshanxing1-ssanjiao1;
        double angel2=acos((double)(-sqrt(2.0)*1.0/4.0));     ///大角度
        angel2=angel2*1.0/p*180.0;
        double ssanjiao2=sqrt(7*1.0/32*1.0)*sqrt(1.0/32.0)*l*l;     ///小三角
        double angel3=360-angel2*2;
        double sshanxing2=angel3*p*l*l*1.0/(360*4)*1.0;  ///大扇形
        double s2=sshanxing2-ssanjiao2;
        double result=2*(s2-s1);
        printf("%.2lf\n",result);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值