简单数学(HDU 5858)

 

cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it? 
 

Give you the side length of the square L, you need to calculate the shaded area in the picture. 

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square. 

InputThe first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).OutputFor each test case, print one line, the shade area in the picture. The answer is round to two digit.Sample Input

1
1

Sample Output

0.29

 

 

 

 

几何,微积分都可以做,微积分做暴力一点,几何做法需要做辅助线

下面介绍几何做法

 

做辅助线

因为图形是确定的,所以图上的所有角度可以根据高中数学只是求出来

代码:

#include<bits/stdc++.h>
#define N 101000
#define INF 0x3f3f3f3f
#define WC 1e-6
typedef long long LL;
using namespace std;
const double sqtwo=sqrt(2.0);//cos acos 都采用弧度
const double PI=acos(-1.0);
double Area_Cir(double r,double rad)//计算半径为r,弧度为rad的扇形面积
{
    return ((r*r*rad)/2.0);
}
int main()
{
    double rad1,rad2,rad3,s1,s2,ans,l,r;
    int t;
    rad1=acos(5.0/(4.0*sqtwo));
    rad2=acos(-1*1.0/(2.0*sqtwo));
    rad3=2*PI-2*rad2;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lf",&l);
        r=l/2.0;
        s1=Area_Cir(r,rad3);
        s2=2.0*r*r*sqtwo*sin(rad1);
        ans=s1+s2-Area_Cir(l,2*rad1);
        printf("%.2lf\n",2*ans);
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值