HDU 5858 Hard problem(计算几何)


Hard problem

Time Limit: 2000/1000 MS (Java/Others)   

 Memory Limit: 65536/65536 K (Java/Others)


Problem Description
cjj is fun with math problem. One day he found a Olympic Mathematics problem for primary school students. It is too difficult for cjj. Can you solve it?


Give you the side length of the square L, you need to calculate the shaded area in the picture.

The full circle is the inscribed circle of the square, and the center of two quarter circle is the vertex of square, and its radius is the length of the square.
 

 

Input
The first line contains a integer T(1<=T<=10000), means the number of the test case. Each case contains one line with integer l(1<=l<=10000).
 

 

Output
For each test case, print one line, the shade area in the picture. The answer is round to two digit.
 

 

Sample Input
1
1
 

 

Sample Output
0.29
 
题意:
  求变成为length的正方形中阴影部分的面积;
 
思路:

建坐标系积分就好了;以参考资料中的D点为原点,然后得到两个圆的方程,联立求交点得到积分区间,然后积分,积分的时候借用三角函数;  http://zhidao.baidu.com/question/571519797


另一种解法也可以用以正方形的中心为原点,以对角线为水平轴,然后得到两个圆的方程,联立求交点得到积分区间,然后积分。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <list>
#define LL long long
#define eps 1e-8
#define maxn 110
#define mod 100000007
#define inf 0x3f3f3f3f
#define mid(a,b) ((a+b)>>1)
#define IN freopen("in.txt","r",stdin);
using namespace std;

int main(int argc, char const *argv[])
{
    //IN;

    int t; cin >> t;
    while(t--)
    {
        double a; scanf("%lf", &a);

        //double ans = a*a/4.0 * asin(sqrt(14.0)/4.0);
        //ans -= a*a * asin(sqrt(14.0)/8.0);
        //ans += a*a * sqrt(7.0) / 8.0;
        //ans *= 2.0;

        double ans = atan(sqrt(7.0)) / 4.0;
        ans -= atan(sqrt(7.0)/5.0);
        ans += sqrt(7.0) / 8.0;
        ans *= a*a*2.0;

        printf("%.2f\n", ans);
    }

    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值