hdu2577 How to Type---DP

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=2577


一:原题内容

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
  
  
3 Pirates HDUacm HDUACM
 

Sample Output
  
  
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 
二:分析理解

 题目大意: 给你一些字符串a~z||A~Z,然后我们按键最少能把他们都打出来,如果开始Cap大写灯是亮的,我们需要打a的话,可以按下cap键,然后再按a,需要两步,但是这下状态变为了大写灯亮,当然我们也可以按下shift,再按下a,需要两步,但是这下状态就变成了大写灯灭。题目要求的是,把这些字母打出来需要的最小按键数目。有一点需要注意,按键完成之后需要使cap键关闭。

解题思路: 用dp[i][1]表示完成i打印Cap灯亮最小的步数,dp[i][0]表示完成i打印Cap灯灭的最小的步数,那么状态转移的时候dp[i][?]只能从dp[i-1][?]中转移,而且选小的,这样就好办了。

三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>  

using namespace std;

char s[105] = "#";
int dp[105][2];

int main()
{
	int test;
	scanf("%d", &test);

	while (test--)
	{
		scanf("%s", s + 1);
		int len = strlen(s + 1);

		dp[0][0] = 0;
		dp[0][1] = 1;

		for (int i = 1; i <= len; i++)
		{
			if (s[i] >= 'A'&&s[i] <= 'Z')
			{
				dp[i][0] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 2);
				dp[i][1] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 1);
			}
			else
			{
				dp[i][0] = min(dp[i - 1][0] + 1, dp[i - 1][1] + 2);
				dp[i][1] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 2);
			}
		}

		printf("%d\n", min(dp[len][0], dp[len][1] + 1));
	}


	return 0;
}





  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值