原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1081
一:原题内容
Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
Sample Output
15
二:分析理解
这道题前身是求一维数组的最大子序列和。这题只是二维而已。
三:AC代码
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int map[110][110];
int main()
{
int n;
int x;
while (~scanf("%d", &n))
{
memset(map, 0, sizeof(map));
for (int i = 1; i <= n; i++)
for (int j = 1; j <= n; j++)
{
scanf("%d", &x);
map[i][j] += (x + map[i][j - 1]);
}
int ans = -1000000;
for (int i = 1; i <= n; i++)//第i列
{
for (int j = i; j <= n; j++)//第j列
{
int maxx = 0;
for (int k = 1; k <= n; k++)//第k行
{
if (maxx < 0)
maxx = 0;
maxx += (map[k][j] - map[k][i - 1]);
if (maxx > ans)
ans = maxx;
}
}
}
printf("%d\n", ans);
}
return 0;
}