To the Max(ACM)最大和矩阵

To the Max
Time Limit: 1000ms, Special Time Limit:2500ms, Memory Limit:32768KB
Total submit users: 926, Accepted users: 794
Problem 10102 : No special judgement
Problem description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 
 
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 
Output
Output the sum of the maximal sub-rectangle.
 
Sample Input
4
0 -2 -7 0
9 2 -6 2
-4 1 -4  1
-1 8  0 -2
Sample Output
15
#include <iostream>
#include <string.h>
#define MIN 0x80000000;
using namespace std;
int a[101][101];
int OneDimSub(int array[],int n){
	int get=0,max=MIN;
	for(int i=0;i<n;i++){
		if(get>0)  
			get=get+array[i];
		else
			get=array[i];
		if(get>max) max=get;
	}
	return max;
}
int solve(int n){
	int array[n];
	int i,j,k,p,max,get;
	max=MIN;
	for(i=0;i<n;i++){
		for(j=i;j<n;j++){
			//缩小成为一维 
			memset(array,0,4*n);
			for(k=i;k<=j;k++){
				for(p=0;p<n;p++)
					array[p]+=a[k][p];
			}
			//解决一维数组最大子段和
			get=OneDimSub(array,n);
			if(get>max) max=get;
		}
	}
	return max;
}
int main(){
	int n;
	cin>>n;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++)
			cin>>a[i][j];
	}
	cout<<solve(n);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

hnu哈哈

请接受直女的么么哒????

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值