Uva 10487 — Closest Sums


Given is a set of integers and then a sequence of queries. A query gives you a number and asks to find a sum of two distinct numbers from the set, which is closest to the query number.

Input

Input contains multiple cases.

Each case starts with an integer n (1<n<=1000), which indicates, how many numbers are in the set of integer. Next n lines contain n numbers. Of course there is only one number in a single line. The next line contains a positive integer m giving the number of queries, 0 < m < 25. The next m lines contain an integer of the query, one per line.

Input is terminated by a case whose n=0. Surely, this case needs no processing.

Output

Output should be organized as in the sample below. For each query output one line giving the query value and the closest sum in the format as in the sample. Inputs will be such that no ties will occur.

Sample input

5

3 
12 
17 
33 
34 
3 
1 
51 
30 
3 
1 
2 
3 
3 
1 
2 
3 

3

1 
2 
3 
3 
4 
5 
6 
0 

Sample output

Case 1:     
Closest sum to 1 is 15.     
Closest sum to 51 is 51.     
Closest sum to 30 is 29.     
Case 2:     
Closest sum to 1 is 3.     
Closest sum to 2 is 3.     
Closest sum to 3 is 3.     
Case 3:     
Closest sum to 4 is 4.     
Closest sum to 5 is 5.     
Closest sum to 6 is 5.
题意:给出n个数 从任意两数之和中 找出与某个数最接近的数,
分析:存数,二分查找,第一次写二分 弱弱的
<pre name="code" class="cpp">#include<stdio.h>
#include<algorithm>
#include<iostream>
using namespace std;
int s[6000000];
int find(int l,int r,int t)//二分查找
{
    if(r-l==1)
        return l;
    int m=l+(r-l)/2;
    if(s[m]<=t&&s[m+1]>=t)
        return m;
    if(s[m]<t)
        return find(m,r,t);
    if(s[m]>t)
        return find(l,m,t);
}
int main()
{
    int n,m,i,j,b;
    int a[1100];
    int nn=0,r;
    while(scanf("%d",&n),n)
    {
        nn++;r=0;
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<n-1;i++)
            for(j=i+1;j<n;j++)
                s[r++]=a[i]+a[j];//将任意两数的和存到s数组中;
        sort(s,s+r);
        printf("Case %d:\n",nn);
        scanf("%d",&m);
        while(m--)
        {
            scanf("%d",&b);
            if(b<=s[0])
                printf("Closest sum to %d is %d.\n",b,s[0]);
            else if(b>=s[r-1])
                printf("Closest sum to %d is %d.\n",b,s[r-1]);
            else
            {
                int k=find(0,r-1,b);
                if(b-s[k]>(s[k+1]-b))
                    printf("Closest sum to %d is %d.\n",b,s[k+1]);
                else
                    printf("Closest sum to %d is %d.\n",b,s[k]);
            }
        }
    }
return 0;
}



 

                
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值