poj 2251 Dungeon Master

poj 2251 Dungeon Master

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C. The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C. 

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form

    Escaped in x minute(s). 


where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

    Trapped! 

Sample Input

 3 4 5
 S....
 .###.
 .##..
 ###.#

 #####
 #####
 ##.##
 ##...

 #####
 #####
 #.###
 ####E

 1 3 3
 S##
 #E#
 ###

 0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

你被关进了地牢里了╥﹏╥…赶快想办法出去吧~

先输入地牢的长宽高,然后再输入地牢,’#’表示墙,’.’表示路,’S’表示你的位置,’E’出口。你一次可以往上下,左右,前后的一个方向走一步。赶快看看能不能走出去吧~
宽搜的水题,只不过这次变成三维的了,不过方法都一样
直接来代码了~

 
#include<iostream>
#include <cstdio>
#include <math.h>
#include <string.h>
#include <queue>
using namespace std;
int L, R, C;
char a[30][30][30];
int dir[6][3]={{1, 0, 0}, {-1, 0, 0}, {0, 1, 0}, {0, -1, 0}, {0, 0, 1}, {0, 0, -1}};
struct Coor
{
int x, y, z, ans;
}s, e;
int ans;
inline bool ok(Coor c)
{
if (a[c.x][c.y][c.z] == '.'&& c.x >= 0 && c.x < L && c.y >= 0 && c.y < R && c.z >= 0 && c.z < C )
{
return true;
}
return false;
}
int bfs()
{
queue<Coor> q;
Coor nxt, now;
q.push(s);
while(!q.empty())
{
now = q.front();
q.pop();
if (now.x == e.x && now.y == e.y && now.z == e.z)
{
ans = now.ans;
return ans;
}
for(int i = 0; i < 6; i++)
{
nxt.x = now.x + dir[i][0];
nxt.y = now.y + dir[i][1];
nxt.z = now.z + dir[i][2];
if (ok(nxt))
{
a[nxt.x][nxt.y][nxt.z] = '!';
nxt.ans = now.ans + 1;
q.push(nxt);
}
}
}
return 0;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("1.txt", "r", stdin);
#endif
int i, j, k;
while(~scanf("%d%d%d", &L, &R, &C) && L)
{
ans = 0;
getchar();
i = 0;
j = 0;
memset(a, 0, sizeof(a));
while (gets(a[i][j]))
{
if (strlen(a[i][j]))
{
j++;
}
else
{
j = 0;
i++;
}
if (i == L)
{
break;
}
}
for (i = 0; i < L; i++)
{
for(j = 0; j < R; j++)
{
for (k = 0; k < C; k++)
{
if (a[i][j][k] == 'S')
{
s.x = i;
s.y = j;
s.z = k;
a[i][j][k] == '.';
break;
}
else if (a[i][j][k] == 'E')
{
e.x = i;
e.y = j;
e.z = k;
a[i][j][k] = '.';
break;
}
}
}
}
s.ans = 0;
ans = bfs();
if (ans)
{
cout << "Escaped in " << ans << " minute(s)." << endl;
}
else
{
cout << "Trapped!" << endl;
}
}
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值