POJ 2406 Power Strings [KMP+循环节规律]

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

题目大意:给一个字符串,要求这个字符串是由多少个连续的子串组成的;

题解:对于next数组, next[len]就是最后一个字符的位置,如果他有相同的子串,则            长度为len-next[len] 所以只需要把next数组求出来然后取余判断,如果没有相              同的,则只有他自己,即为1;

AC代码:

#include <iostream>
#include <cmath>
#include<cstdio>
#include <cstring>
#include <algorithm>
#define N 10000005
using namespace std ;
char a[N] ;
int len , n , next[N];
void kkk()
{
    int i , j ;
    i = 0;
    j = next[0] = -1;
    while(i < len)
    {
        while(j!=-1&&a[i]!=a[j])
             j = next[j];
        next[++i] = ++j;
    }
}

int main()
{
    while(scanf("%s",a))
    {
        if(a[0]=='.') break;
        len = strlen(a);
        memset(next,0,sizeof(next));
        kkk();
        int ans ;
        if(len%(len-next[len])==0) ans = len/(len-next[len]);
        else ans = 1;
        cout<<ans<<endl;
    }
    return 0 ;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值