POJ 3641 快速幂+素数判断

Description

Fermat's theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide byp, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题目大意(百度):给定两个数, p ,a ; 如果p是素数,输出n;

否则判断 a^p%p是否等于a ,是输出yes; 否则输出no;

除了当时题意看不懂 这个题做起来没有任何困难。。。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define ll long  long 
#define inf 1000000007
using namespace std ;
ll quick(ll a , ll b , ll mod)
{
	ll res = 1 ;
	a = a % mod ; 
	while(b)
	{
		if(b%2) res = res * a % mod ;
		b /= 2 ; 
		a = a * a % mod ;
	}
	return res ; 
}

ll prime(ll a )
{
	if(a==1||a==0) return false ;
	for(int i =  2 ; i<=sqrt(a) ;i++)
	{
		if(a%i==0) return false ;
	}
	return true ;
}
int main()
{
	ll p , a ; 
	while(cin>>p>>a , a + p)
	{
		ll judge ;
		if(prime(p))
		{
			 printf("no\n");
			 continue;
		}
		else 
		{
			judge = quick(a, p,p);
			if(judge==a) 
			{
				printf("yes\n");
				continue ;
			}
			else 
			{
				printf("no\n");
				continue;
			}
		}
	}
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值