POJ 3984 记录路径的BFS

思路:从右下角往左上角开始搜索,然后搜到一个位置就把当前位置的上一个位置保存起来;

           然后rear会一直增加,所以输出的时候,

           就会从大到小输出,就做到了从左上到右下的输出;

Description

定义一个二维数组:
int maze[5][5] = {

 0, 1, 0, 0, 0,

 0, 1, 0, 1, 0,

 0, 0, 0, 0, 0,

 0, 1, 1, 1, 0,

 0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)


PS:以前写队列,rear=front=0; 后直接++rear,在这里好像不行,以后还是按照front=0,rear=1来写吧;


ac代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
struct node{
	int x , y , pre;
}q[30];
int ma[50][50];
int bfs()
{
	int front= 0 ,rear=1,i;
	q[0].x=4;q[0].y=4;q[0].pre=-1;
	ma[4][4]=1;
	while(front<rear)
	{
		for(i=0;i<4;i++)
		{
			q[rear].x=dir[i][0]+q[front].x;
			q[rear].y=dir[i][1]+q[front].y;
			q[rear].pre=front;
			if(q[rear].x>=0&&q[rear].x<5&&q[rear].y>=0&&q[rear].y<5&&!ma[q[rear].x][q[rear].y])
			{
				ma[q[rear].x][q[rear].y]=1;
				if(q[rear].x==0&&q[rear].y==0)
				{
					return rear;
				}
				rear++;
			}
		}
		front++;
	}
	return -1;
}

int main()
{
	int i , j;
	for(i=0;i<5;i++)
	{
		for(j=0;j<5;j++)
		{
			cin>>ma[i][j];
		}
	}
	int t = bfs();
	while(t!=-1)
	{
		printf("(%d, %d)\n",q[t].x,q[t].y);
		t=q[t].pre;
	}
	return 0 ;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Kelisita

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值