Minimum Cut

Minimum Cut
Time Limit:2000MS Memory Limit:102400KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Given a simple unweighted graph G (an undirected graph containing no loops nor multiple edges) with n nodes and m edges. Let T be a spanning tree of G .
We say that a cut in G respects T if it cuts just one edges of T.

Since love needs good faith and hypocrisy return for only grief, you should find the minimum cut of graph G respecting the given spanning tree T.

Input
The input contains several test cases.
The first line of the input is a single integer t (1t5) which is the number of test cases.
Then t test cases follow.

Each test case contains several lines.
The first line contains two integers n (2n20000) and m (n1m200000) .
The following n1 lines describe the spanning tree T and each of them contains two integers u and v corresponding to an edge.
Next mn+1 lines describe the undirected graph G and each of them contains two integers u and v corresponding to an edge which is not in the spanning tree T.

Output
For each test case, you should output the minimum cut of graph G respecting the given spanning tree T.

Sample Input
1
4 5
1 2
2 3
3 4
1 3
1 4

Sample Output
Case #1: 2

分析:
G是一个图,T是他的生成树。问至少去掉多少天边可以使这个图不连通,却只能去掉生成树中的一条边。
由于只能去掉生成树中的一条边,所以一定是去掉在生成树中度为1的边(入度+出度),并且在整个图中度最少的节点,使之不连通。td[i]表示j节点i在生成树中的度,gd[i]表示节点i在生成树之外的度。所以结果就是td[i]==1,且min(gd[i]).

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

const int maxn = 20010;
int td[maxn],gd[maxn];

int main()
{
    int t,n,m,a,b,cas=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(td,0,sizeof(td));
        memset(gd,0,sizeof(gd));
        cas++;
        scanf("%d%d",&n,&m);
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d",&a,&b);
            td[a]++;td[b]++;
        }
        for(int i=0;i<m-n+1;i++)
        {
            scanf("%d%d",&a,&b);
            gd[a]++;gd[b]++;
        }
        int ans = 20010;
        for(int i=1;i<=n;i++)
        {
            if(td[i]==1)
            {
                ans=min(ans,td[i]+gd[i]);
            }
        }
        printf("Case #%d: %d\n",cas,ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值