POJ2914 Minimum Cut Stoer-Wagner

 

Minimum Cut

Time Limit: 10000MS

 Memory Limit: 65536K
Total Submissions: 6414 Accepted: 2670
Case Time Limit: 5000MS

Description

Given an undirected graph, in which two vertices can be connected by multiple edges, what is the size of the minimum cut of the graph? i.e. how many edges must be removed at least to disconnect the graph into two subgraphs?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (2 ≤ N ≤ 500, 0 ≤ MN × (N − 1) ⁄ 2) in one line, whereN is the number of vertices. Following are M lines, each line containsM integers A, B and C (0 ≤ A, B <N, AB, C > 0), meaning that there C edges connecting verticesA and B.

Output

There is only one line for each test case, which contains the size of the minimum cut of the graph. If the graph is disconnected, print 0.

Sample Input

 

3 3
0 1 1
1 2 1
2 0 1
4 3
0 1 1
1 2 1
2 3 1
8 14
0 1 1
0 2 1
0 3 1
1 2 1
1 3 1
2 3 1
4 5 1
4 6 1
4 7 1
5 6 1
5 7 1
6 7 1
4 0 1
7 3 1

Sample Output

2
1
2

 

 

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>

using namespace std;

#define MAXN 600
#define INF 0x3ffffff

int n,g[MAXN][MAXN];
int b[MAXN],dist[MAXN];

int Min_Cut_Phase(int ph,int &x,int &y)
{
    int t=1;
    b[t]=ph;
    for(int i=1;i<=n;i++)
        if(b[i]!=ph) dist[i]=g[1][i];
    for(int i=1;i<n;i++)
    {
        x=t;t=0;
        for(int j=1;j<=n;j++)
            if(b[j]!=ph && (!t||dist[j]>dist[t])) t=j;
        b[t]=ph;
        for(int j=1;j<=n;j++)
            if(b[j]!=ph) dist[j]+=g[t][j];
    }
    y=t;
    return dist[t];
}

void Merge(int x,int y)
{
    if(x>y) swap(x,y);
    for(int i=1;i<=n;i++)
        if(i!=x && i!=y)
            g[i][x]+=g[i][y],g[x][i]+=g[i][y];
    if(y==n) return;
    for(int i=1;i<n;i++)
        if(i!=y)
        {
            swap(g[i][y],g[i][n]);
            swap(g[y][i],g[n][i]);

        }
}

int  Stoer_Wagner()
{
    int ret=INF;
    int x,y;
    memset(b,0,sizeof(b));
    for(int i=1;n>1;i++,n--)
    {
        ret=min(ret,Min_Cut_Phase(i,x,y));
        Merge(x,y);
    }
    return ret;
}

int m;

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(g,0,sizeof(g));
        int x,y,c;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&x,&y,&c);
            x++,y++;
            g[x][y]+=c;
            g[y][x]=g[x][y];
        }
        printf("%d\n",Stoer_Wagner());
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值