poj 2342 Anniversary party 树形DP

265 篇文章 1 订阅
15 篇文章 0 订阅

Anniversary party
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3686 Accepted: 2056

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source



看了网上很多关于这道题的代码,感觉很多人写的都很长,自己AC了一下,贴到这里。


其实拿到这道题感觉DP的思路自己还是可以找到的,没有想到的是如何存树,用邻接表存代码会较长,而且维护起来比较多。比较简洁的方法是用一个vector数组来存,vector[i]保存第i个结点的所有children。还有一点没有想到的是如何较方便地保存DP的数据,用一个二维数据即可。


另外有一点就是可以利用son数组来记录每个结点是否为某个结点的儿子,这种方法便于在O(n)的时间内找到根。


定义max宏时自己居然写成了max(a,b) (a)>(b)?(a:b),这点以后要多加注意!


好了,上代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<stdlib.h>
#define max(a,b) (a)>(b)?a:b // max(a,b) (a)>(b)?(a:b)   杯具了

using namespace std;
vector<int> employee[6001];
int rating[6001];
bool son[6001];//表示这个结点是否为某个结点的son,false的为根 
int N,L,K;
int dp[6001][2];//dp[i][1]表示第i个结点有参与,dp[i][0]表示第i个结点没有参与 

int DFS(int root){
    int i;
    if( !employee[root].empty() ){
        
        for(i=0;i<employee[root].size();i++){

             DFS(employee[root][i]);
             dp[ root ][1]+=dp[ employee[root][i] ][0];
             dp[ root ][0]+=max(dp[ employee[root][i] ][1], dp[ employee[root][i] ][0] ); 
        }
        dp[ root ][1]+= rating[root];
        
        return max( dp[root][1],dp[root][0] );        
    } 
    else{
        dp[root][0]=0;   
        dp[root][1]=rating[root]; 
        return rating[root];
    }
} 
int main(){
    
    int i,root;
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        scanf("%d",&rating[i]);
    }
    memset(son,0,sizeof(son));
    
    while( scanf("%d%d",&L,&K)==2 && (L||K) ){
        son[L]=true;
        employee[K].push_back(L);
    } 
    
    for(i=1; i<=N &&son[i] ;i++){}
    root=i;         //寻找树根
    
    memset(dp,0,sizeof(dp)); 
    printf("%d\n",DFS(root));
    
    //system("pause");
    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值