POJ(1068)(模拟)(栈)思想

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
大意:q数列是找每一个右括号的左面有几个左括号,w数列是找每一个右括号的里面有几个已匹配括号(包括它本身),此题不用考虑未匹配的情况,让我感觉难度下降
 
 
代码:
#include<stdio.h>
#include<string.h>
int q[30],w[30];
char s[100];
int h1(int n);
int h2(int n);
int g1(int n);
int g2();
int main()
{
    int t=0;
    scanf("%d",&t);
    while(t)
    {
        int n,l1,l2;
        memset(s,'\0',sizeof(s));
        scanf("%d",&n);
        int i;
        for(i=0;i<n;i++)
        {
            scanf("%d",&q[i]);
        }
        l1=g1(n);//把整形数组转化为字符数组,并获得数组的长度
        l2=h2(l1);//把q转化为w,并获得数组长度
        for(i=0;i<l2;i++)
        {
            printf("%d",w[i]);
            if(i<n-1)
            printf(" ");
        }
        if(t>1)
        printf("\n");
        t--;
    }
}
int g1(int n)
{
    int i,j,k;
    j=0;
    k=0;
    for(i=0;i<n;i++)
    {
        for(;k<q[i];k++)
        {
            s[j]='(';
            j++;
        }
        s[j]=')';
        j++;
        k=q[i];
    }
    return j;//返回有多少个字符
}
int h2(int n)
{
    int i,j,k;
    int a=0;
    for(i=0;i<n;i++)
    {
        if(s[i]==')')
        {
            w[a]=h1(i);
            a++;
        }
    }
    return a;
}
int h1(int n)
{
    int i,j=0,k=0;
    for(i=n;i>=0;i--)
    {
        if(s[i]==')')
        k++;
        if(s[i]=='(')
        {
            j++;
            k--;
        }
           if(k==0)
           return j;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值