1027. Colors in Mars (20)

102 篇文章 0 订阅
26 篇文章 0 订阅

1027. Colors in Mars (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456
3个10进制数,范围0-168,把它用转换撑用13进制表示的RGB且每个要占两位
比如    6十进制变换后06十三进制
       12十进制变换后0C十三进制
       13十进制变换后10十三进制 
下面的三个代码在测试中的效果一样


 
 

评测结果

时间结果得分题目语言用时(ms)内存(kB)用户
8月01日 10:20答案正确201027C++ (g++ 4.7.2)1436datrilla

测试点

测试点结果用时(ms)内存(kB)得分/满分
0答案正确118010/10
1答案正确14362/2
2答案正确13082/2
3答案正确13082/2
4答案正确13082/2
5答案正确13002/2
#include<iostream>   
#include<string>
using namespace std; 
char getRadix(int num)
{      
  if (num <= 9)
    return num + '0';
  return num + 'A' - 10;  
   
}
int main()
{     
  int red, green, blue;
  cin >> red >> green >> blue;  
  cout << "#";
  cout << getRadix(red / 13)<< getRadix(red % 13) << getRadix(green / 13) << getRadix(green % 13)<< getRadix(blue / 13)<< getRadix(blue % 13) << endl;  
  system("pause");   
  return 0;
}


================================================
#include<iostream>   
#include<string>
using namespace std; 
char getRadix(int num)
{      
  if (num <= 9)
    return num + '0';
  return num + 'A' - 10;  
   
}
int main()
{     
  int red, green, blue;
  string RGB;
  cin >> red >> green >> blue;  
  RGB+=  getRadix(red / 13)  ;
  RGB += getRadix(red % 13);
  RGB += getRadix(green / 13);
  RGB += getRadix(green % 13);
  RGB += getRadix(blue / 13);
  RGB += getRadix(blue % 13);
  cout << "#" << RGB << endl;
  system("pause");   
  return 0;
}
=========================================================
 
#include<iostream>   
#include<string>
using namespace std; 
string getRadix(int num)
{    
  char c;
  string str; 
  if (num <= 9)
    c= num + '0';
  else c= num + 'A' - 10;  
  str = c ;
  return str;
}
int main()
{     
  int red, green, blue;
  string RGB;
  cin >> red >> green >> blue;  
  RGB=  getRadix(red / 13)+getRadix(red % 13)+getRadix(green / 13) + getRadix(green % 13) + getRadix(blue/13) + getRadix(blue%13);
  cout << "#" << RGB << endl;
  system("pause");   
  return 0;
}
====================================
下面的这个在pat上面是不可以的,在vs2013社区版可以。想了想,我当初做的数据库用的是C#,有的用中文命名,感觉在其他环境下可能动不了。
#include<iostream>   
#include<string>
using namespace std;
char (int )
{
  if ( <= 9)
    return  + '0';
  return  + 'A' - 10;

}
int main()
{
  int , 绿, ;
  cin >> >>绿>>;
  cout << "#";
  cout << ( / 13) << ( % 13) << (绿 / 13) << (绿 % 13) << ( / 13) << ( % 13) << endl;
  system("pause");
  return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值