Cow Contest poj 3615

Cow Contest
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12168 Accepted: 6760

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source


一道神奇的题目,没想到floyd还能这么用,其实就是让赢得到输的那条边为1,然后用floyd去计算看能不能通过其他点去打败另一个,然后在最后用双重for循环去检索比他弱的和比他强的是否够n-1个,假如够了就说明他的排名可以去确定了
#include<stdio.h>
#include<string.h>
int main()
{
    int map1[300][300];
    int m,n,i,j,a,b,k;
    while(~scanf("%d%d",&n,&m))
    {
        memset(map1,0,sizeof(map1));
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&a,&b);
            map1[a][b]=1;
        }
        for(k=1; k<=n; k++)
            for(i=1; i<=n; i++)
                for(j=1; j<=n; j++)
                    if(map1[i][k]&&map1[k][j])
                        map1[i][j]=1;
        int ans=0;
        for(i=1; i<=n; i++)
        {
            int t=0;
            for(j=1; j<=n; j++)
                if(map1[i][j]||map1[j][i])
                    t++;
            if(t==n-1)
                ans++;
        }
        printf("%d\n",ans);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值