Semi-prime H-numbers 筛选法

Semi-prime H-numbers
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6868Accepted: 2927

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers areH-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62
 
 
 
这个题目的意思 H-numbers 是4n+1的数,H-primes是指那些因子只有自身和1的 H-numbers 相乘得到的数字,如5
=1*5算是,但是25=5*5=1*25,就不算了,他让我们求出的数Semi-prime H-numbers是指由H-primes相乘得到的数字,
举个例子来说,45=5*9,因为5和9都只有1*5,9=1*9组成,这时候可能有人问9=3*3,不是素数啊,这个数的意思,它
的因子必须是H-numbers ,所以3不能算呗,所以45就是了,因为这个范围不大,所以筛选法就可以求出来了
 
 
那么这个题目的思路是啥的,我们要保证这个数的两个因子都符合条件,也就是说5*9=45,而45是这个数,但是45这
个数就不能算是了,所以我们不能选择45再作为因子了,我们用两个for循环逐层遍历,但是有人可能会问我们这样
能保证因子全是吗?,当然可以当我们遍历所以因子,列入当我们遍历到25时,我们就不能算了,因为在一开始5*5
就已经标记它不行了!!!!
 
还有一点我本来想求出求出那些数是就行了,但是还是过不了,tle,我们用每个范围对应的情况都求出就是了,所以
直接输出数组的值就好了
 
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
#define M 1000001
int h[M+10];
int count;
void table()
{
    memset(h,0,sizeof(h));
    int i,j,s;
    for(i=5; i<=M; i=i+4)
    {
        for(j=5; j<=M; j=j+4)
        {
            s=i*j;
            if(s>M)
            {
                break;
            }
            if(h[i]==0&&h[j]==0)
                h[s]=1;
            else
                h[s]=-1;

        }
    }
    count=0;
    for(i=1;i<=M;i++)
    {
        if(h[i]==1)
        {
          count++;
        }
        h[i]=count;
    }
}
int main()
{
    int i,j,k,n;
    table();
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
        break;
       /* count=0;
        for(i=1; i<=n; i++)
        {
            if(h[i]==1)
           {
               count++;
           }
        }
        printf("%d %d\n",n,count);*/
        printf("%d %d\n",n,h[n]);
    }
    return 0;
}

 
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值