HDU 4465 Candy 概率期望值的对数优化

题目链接:http://acm.split.hdu.edu.cn/showproblem.php?pid=4465

Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2888    Accepted Submission(s): 1304
Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 10 5) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10 -4 would be accepted.
 

Sample Input
  
  
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
  
  
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000
 

Source
【分析】:

原来这是紫书上的一道题。。

题意有两个盒子,各n个糖果,每天从其中的1个盒子中拿一个糖果。

每天从一个盒子拿的概率是p,另一个(1-p);

某一天打开一个盒子发现空时,另一个盒子中的糖果数量的期望值是多少?


至关重要的一点,起初忽略了,上面红字!这一天相当于拿糖时空手而归。

假设A盒子,B盒子。取A的概率为p。


假设发现A空了的那一天,从B中已经取走了i个

则这种事件发生的概率为 C(n+i, i) * p^(n+1) *(1-p)^i

但是n的取值范围可达20万,组合数特别大,p的n+1次方又特别小,直接算会损失精度。

自然对数的优化登场。

令V = C(n+i, i) * p^(n+1) *(1-p)^i  

这三个数相乘,整体取对数,得ln(V)= ln(C(n+i, i)) + (n+1)*ln(p)  +  i*ln(1-p)  


计算过程用对数,算完之后得到ln(V)

那么该状态的概率V = e^ln(V),这时的概率将大大减少精度损失。


然后的话就是遍历i求每个状态的V*i ,求和,即为答案。别忘了A和B盒子交换一下的情况。


另外,组合数也是对数优化的,把求组合数过程的阶乘,取对数ln(n!) =ln(n) + ln(n-1) +.....

这样就能不爆longlong

【代码】:

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <iostream>
using namespace std;
double lnc[404040];
double lns[401010];//ln(i)的前n项和
void init()
{
    lns[1]=0;//特殊
    for(int i=1;i<=200010;i++)
        lns[i]=log(i)+lns[i-1];
}
double lnC(int n,int m)
{
    if(m==0)return 0;
    return (lns[n]-lns[n-m])-lns[m];
}
int main()
{
    init();
    int n,r=1;
    double p;
    while(cin>>n>>p)
    {
        double ans=0;
        for(int i=0;i<n;i++)
        {
            double t=lnC(n+i,i)+(n+1)*log(p)+i*log(1-p);
            ans+=exp(t)*(n-i);
            t=lnC(n+i,i)+(n+1)*log(1-p)+i*log(p);//换盒子
            ans+=exp(t)*(n-i);
        }
        printf("Case %d: %lf\n",r++,ans);
    }
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

雪的期许

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值