POJ 2153 Rank List map

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other. 

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam. 

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output

1
2

感觉这道题一开始输入的数据没什么太大用处,至少使用map的时候是这样的,因为无论是创建还是插入都是动态的,而且后面在输入成绩的时候还会输入学生的姓名,完全可以在后面插入数据,所以我也就没有对之前的数据做任何处理,完全是白白输入浪费时间,但是如果要是用数组的话就需要事先知道有多少人,好动态创建数组,要是定义静态数组的话,还是没什么用,有一点需要注意,如果用map,那么map默认是按key进行排序的,也就是说输入完数据之后是按照姓名的字典序排的,而不是成绩,因此需要遍历整个map来计算名次,当然也可以让map通过value进行排序,在这里不再详述,以前总结的map使用方法已经讲到,有兴趣可以查阅。



#include<iostream>
#include<string>
#include<map>
using namespace std;
int main()
{
	map<string,int>score_list;
	map<string,int>::iterator it;
	int num_s,num_e,score,i;
	string name;
	cin>>num_s;
	getchar();
	for(i=0;i<num_s;i++)
	{
		getline(cin,name);
		//cout<<name<<endl;
		score_list[name]=0;
	}
	cin>>num_e;
	while(num_e--)
	{
		for(i=0;i<num_s;i++)
		{
			cin>>score;
			getchar();
			getline(cin,name);
			//cout<<name<<endl;
			score_list[name]+=score;
		}
		i=num_s;
		//cout<<i<<endl;
		//for(it=score_list.begin();it!=score_list.end();it++)
		//cout<<it->first<<' '<<it->second<<endl;
		for(it=score_list.begin();it!=score_list.end();it++)
		{
			if(it->second<=score_list["Li Ming"]&&it->first!="Li Ming")
			{
				i--;
			}
		}
		cout<<i<<endl;
	}
	return 0;
}





评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值