POJ 2376 Cleaning Shifts 【贪心 区间】

Cleaning Shifts
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14669 Accepted: 3730

Description

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed. 

INPUT DETAILS: 

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10. 

OUTPUT DETAILS: 

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

恩,题目大意就是说,从1到T区间内,必须保证每个点都有牛在工作,给出每头牛的工作时间,求需用到的最小的牛的数量。恩,这里是先排序在找最优区间计数,不难的一道题,卡了两天了,多此一举造成的错。。。。


这里给出一组测试数据

5 15

1 10

3 7

2 12

13 15

4 15

输出应该是2  若按下面代码中本来的判断条件,会将2 12 这个非最优区间计数 因为这里有 3 7 的存在那个条件会终止循环导致错过最优区间

//按开始时间排序
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 30000
using namespace std;

struct node
{
    int s,e;
};
node cow[maxn];

bool cmp(node a,node b)
{
    if(a.s!=b.s)
        return a.s<b.s;
    return a.e>b.e;
}

int main()
{
    int n,t,time,cnt;
    while(~scanf("%d%d",&n,&t))
    {
        for(int i=0;i<n;++i)
            scanf("%d%d",&cow[i].s,&cow[i].e);
        sort(cow,cow+n,cmp);
        if(cow[0].s>1)
        {
            printf("-1\n");
            continue;
        }
        time=cow[0].e;
        cnt=1;
        for(int i=1;i<n;++i)
        {
            if(cow[i].s<=time+1&&cow[i].e>time)
            {
                int mark=i;
                while(cow[i].s<=time+1&&i<n)//开始这里条件为while(cow[i].e>time&&cow[i].s<=time+1&&i<n)错的
                {
                    if(cow[i].e>cow[mark].e)
                        mark=i;
                    i++;
                }
                time=cow[mark].e;
                cnt++;
                i=mark;
                if(time>=t)
                    break;
            }
        }
        if(time>=t)
            printf("%d\n",cnt);
        else
            printf("-1\n");
    }
    return 0;
}

这个是按末尾排序,依然是上面会将非最优区间排序的测试数据为:

5 15

1 4

5 13

8 15

9 12

1 10

输出应该是2 这里是由于 9 12 的存在

//按末尾排序
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 30000
using namespace std;
struct node
{
    int s,e;
};
bool cmp(node a,node b)
{
    if(a.e!=b.e)
        return a.e>b.e;
    return a.s<b.s;
}
node cow[maxn];
int main()
{
    int n,t;
    while(~scanf("%d%d",&n,&t))
    {
        for(int i=0;i<n;++i)
            scanf("%d%d",&cow[i].s,&cow[i].e);
        sort(cow,cow+n,cmp);
        if(cow[0].e<t)
        {
            printf("-1\n");
            continue;
        }
        int s=cow[0].s,cnt=1;
        for(int i=1;i<n;++i)
        {
            if(cow[i].e+1>=s&&cow[i].s<s)
            {
                int mark=i;
                while(cow[i].e+1>=s&&i<n)//开始这里为while(cow[i].s<s&&cow[i].e+1>=s&&i<n)
                {
                    if(cow[i].s<cow[mark].s)
                        mark=i;
                    i++;
                }
                s=cow[mark].s;
                cnt++;
                if(s==1)
                    break;
                i=mark;
            }
        }
        if(s>1)
            printf("-1\n");
        else
            printf("%d\n",cnt);
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值