【HDU 5904 LCIS + dp】

47 篇文章 3 订阅
43 篇文章 0 订阅

LCIS
Problem Description
Alex has two sequences a1,a2,…,an and b1,b2,…,bm. He wants find a longest common subsequence that consists of consecutive values in increasing order.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1≤n,m≤100000) – the length of two sequences. The second line contains n integers: a1,a2,…,an (1≤ai≤106). The third line contains n integers: b1,b2,…,bm (1≤bi≤106).

There are at most 1000 test cases and the sum of n and m does not exceed 2×106.

Output
For each test case, output the length of longest common subsequence that consists of consecutive values in increasing order.

Sample Input
3
3 3
1 2 3
3 2 1
10 5
1 23 2 32 4 3 4 5 6 1
1 2 3 4 5
1 1
2
1

Sample Output
1
5
0

Source
BestCoder Round #87

Recommend
wange2014 | We have carefully selected several similar problems for you: 5906 5905 5903 5902 5901

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
const int KL = 1000011;
int pa1[KL],pa2[KL];
int dp1[KL],dp2[KL];
int main()
{
    int i,j,N,T,n,m,ans;
    scanf("%d",&T);
    while(T--)
    {
        ans = 0;
        scanf("%d%d",&n,&m);
        for(i = 1 ; i <= n ; i++){
            scanf("%d",&pa1[i]);
            dp1[pa1[i]] = max(dp1[pa1[i]], dp1[pa1[i] - 1] + 1);
        }
        for(i = 1 ; i <= m ; i++){
            scanf("%d",&pa2[i]);
            dp2[pa2[i]] = max(dp2[pa2[i]],dp2[pa2[i] - 1] + 1);
        }
        for(i = 1 ; i <= n ; i++){
            ans = max(ans,min(dp1[pa1[i]] , dp2[pa1[i]]));
            dp1[pa1[i]] = 0;
        }
        for(i = 1 ; i <= m ; i++)
            dp2[pa2[i]] = 0;
        printf("%d\n",ans);
    }
    return 0 ;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值