PAT--1069. The Black Hole of Numbers

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the “black hole” of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
… …

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0, 10000).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation “N - N = 0000”. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题解

注意n是可以小于1000的。。

#include <bits/stdc++.h>
using namespace std;

int n;

int convert(int n, int mode){
    int num[4] = {0}, k = 0;
    while(n){
        num[k++] = n % 10;
        n /= 10;
    }
    if(mode) sort(num, num + 4, [](int a, int b){ return a > b; });
    else sort(num, num + 4);
    int ret = 0, t = 1;
    for(int i = 3; i >= 0; --i) ret += num[i] * t, t *= 10;
    return ret;
}

int main(){

    cin >> n;
    int a = convert(n, 1), b = convert(n, 0);
    int c = a - b;
    while(c && c != 6174){
        printf("%04d - %04d = %04d\n", a, b, c);
        a = convert(c, 1), b = convert(c, 0);
        c = a - b;
    }
    printf("%04d - %04d = %04d\n", a, b, c);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值