POJ 2386--Lake Counting [dfs] 《挑战程序设计竞赛》2.1

题目链接

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.

Input

Line 1: Two space-separated integers: N and M

Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

Output

Line 1: The number of ponds in Farmer John’s field.

Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.

Sample Output

3

Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

Source

USACO 2004 November

题目大意:

有一个大小为 N×M 的园子,雨后积起了水。八连通的积水被认为是连接在一起的。请求出
园子里总共有多少水洼?(八连通指的是下图中相对 W 的+的部分)
+++
+W+
+++

题解:

用f[][] 记录被访问过的位置, 用dfs搜索

代码:

#include <iostream>
#define MAX_N 110
#define MAX_M 110
using namespace std;

char a[MAX_N][MAX_M];
bool f[MAX_N][MAX_M];
int N, M;
int cnt = 0;
int fx[] = {0, 1, 0, -1, 1, 1, -1, -1};
int fy[] = {1, 0, -1, 0, 1, -1, 1, -1};

void dfs(int x, int y) {
    f[x][y] = true;
    for (int i = 0; i < 8; i++) {
    int tx = x + fx[i];
    int ty = y + fy[i];
    if (!f[tx][ty] && a[tx][ty] == 'W')
        dfs(tx, ty);
    }
}

int main() {
    cin >> N >> M;
    for (int i = 0; i < N; i++) 
    for (int j = 0; j < M; j++) 
        cin >> a[i][j];

    for (int i = 0; i < N; i++) {
    for (int j = 0; j < M; j++) {
        if (!f[i][j] && a[i][j] == 'W') {
        cnt++;
        dfs(i, j);
        }
    }
    }
    cout << cnt << endl;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值