hdoj1002A + B Problem II(大数相加)

117 篇文章 0 订阅
4 篇文章 0 订阅
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	scanf("%d",&n);
	int k=1;
	while(n--)
	{
		char a[1001],b[1001],c[1001];
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		scanf("%s %s",a,b);
		int s1=strlen(a),s2=strlen(b),p=0;
		if(s1<s2)
		{
			int t;
			t=s1;
			s1=s2;
			s2=t;
			p++;
		}
	for(int i=s1-1,j=s2-1;i>=0;i--,j--)
	{
		if(p==0)
		{
			if(j>=0)
			{
			c[i+1]+=(a[i]+b[j]-'0'-10);
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
			}
			else
			{
				c[i+1]+=(a[i]-10);
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
				}	
		}
		else
		{
			if(j>=0)
			{
			c[i+1]+=a[j]+b[i]-'0'-10;
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
			}
			else 
			{
			c[i+1]+=b[i]-10;
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
			}
		}
	}
	printf("Case %d:\n%s + %s = ",k++,a,b);
	if(c[0]!=0)
	printf("%d",c[0]);
	for(int i=1;i<=s1;i++)
	printf("%c",c[i]);
	if(n!=0)
	printf("\n\n");
	else
	printf("\n");
	}
	return 0;
}

思路:这道题用两个数组保存大数,然后用另一个数组保存每个位置相加的数。超过十就-10,前一位加一。最后输出注意格式还有过程中注意最后一位是否大于十,大于的话还要进一位。

 

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值