hdoj1002A + B Problem II(大数相加)

117 篇文章 0 订阅
4 篇文章 0 订阅
Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 

代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int n;
	scanf("%d",&n);
	int k=1;
	while(n--)
	{
		char a[1001],b[1001],c[1001];
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		memset(c,0,sizeof(c));
		scanf("%s %s",a,b);
		int s1=strlen(a),s2=strlen(b),p=0;
		if(s1<s2)
		{
			int t;
			t=s1;
			s1=s2;
			s2=t;
			p++;
		}
	for(int i=s1-1,j=s2-1;i>=0;i--,j--)
	{
		if(p==0)
		{
			if(j>=0)
			{
			c[i+1]+=(a[i]+b[j]-'0'-10);
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
			}
			else
			{
				c[i+1]+=(a[i]-10);
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
				}	
		}
		else
		{
			if(j>=0)
			{
			c[i+1]+=a[j]+b[i]-'0'-10;
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
			}
			else 
			{
			c[i+1]+=b[i]-10;
		if(c[i+1]<48)
		{
			c[i+1]+=10;
		}
		else 
		c[i]++;
			}
		}
	}
	printf("Case %d:\n%s + %s = ",k++,a,b);
	if(c[0]!=0)
	printf("%d",c[0]);
	for(int i=1;i<=s1;i++)
	printf("%c",c[i]);
	if(n!=0)
	printf("\n\n");
	else
	printf("\n");
	}
	return 0;
}

思路:这道题用两个数组保存大数,然后用另一个数组保存每个位置相加的数。超过十就-10,前一位加一。最后输出注意格式还有过程中注意最后一位是否大于十,大于的话还要进一位。

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值