求 f(x,n)

求 f(x,n)

题目描述

已知 f ( x , n ) = n + ( n − 1 ) + ( n − 2 ) + . . . + 2 + 1 + x f(x,n)=\sqrt{n+\sqrt{(n-1)+\sqrt{(n-2)+\sqrt{...+2+\sqrt{1+x}}}}} f(x,n)=n+(n1)+(n2)+...+2+1+x

计算 f f f 的值。

输入格式

输入 x x x n n n

输出格式

函数值,保留两位小数。

样例 #1

样例输入 #1

4.2 10

样例输出 #1

3.68

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射/*  */
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    double x,n;
    cin>>x>>n;
    double ans=x;
    
    for(ll y=1;y<=n;y++)
        ans=sqrt(y+ans);
    
    printf("%.2f",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值