Maximize?

Maximize?

题面翻译

给你一个整数 x x x 。您的任务是找出任意整数 y y y ( 1 ≤ y < x ) (1\le y<x) (1y<x) ,使得 gcd ⁡ ( x , y ) + y \gcd(x,y)+y gcd(x,y)+y 最大。

如果有不止一个 y y y 满足该语句的要求,那么你可以找出任何一个。

题目描述

You are given an integer x x x . Your task is to find any integer y y y ( 1 ≤ y < x ) (1\le y<x) (1y<x) such that gcd ⁡ ( x , y ) + y \gcd(x,y)+y gcd(x,y)+y is maximum possible.

Note that if there is more than one y y y which satisfies the statement, you are allowed to find any.

gcd ⁡ ( a , b ) \gcd(a,b) gcd(a,b) is the Greatest Common Divisor of a a a and b b b . For example, gcd ⁡ ( 6 , 4 ) = 2 \gcd(6,4)=2 gcd(6,4)=2 .

输入格式

The first line contains a single integer t t t ( 1 ≤ t ≤ 1000 1 \le t \le 1000 1t1000 ) — the number of test cases.

Each of the following t t t lines contains a single integer x x x ( 2 ≤ x ≤ 1000 2 \le x \le 1000 2x1000 ).

输出格式

For each test case, output any y y y ( 1 ≤ y < x 1 \le y < x 1y<x ), which satisfies the statement.

样例 #1

样例输入 #1

7
10
7
21
100
2
1000
6

样例输出 #1

5
6
18
98
1
750
3

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

ll gcd(ll a,ll b)
{
    if(!b) return a;
    else return gcd(b,a%b);
}

void solve()
{
    ll x;
    cin>>x;

    ll op=1,mx=0;
    for(ll i=1;i<x;i++)
    {
        ll ans=gcd(x,i)+i;
        if(ans>mx)
        {
            op=i;
            mx=ans;
        }
    }
    cout<<op<<endl;
}

int main()
{
    ll t;
    cin>>t;

    while(t--) solve();

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值