再求 f(x,n)

再求 f(x,n)

题目描述

已知

f ( x , n ) = x n + x ( n − 1 ) + x ( n − 2 ) + ⋮ ⋯ + x 1 + x f(x,n)=\dfrac{x}{n+\dfrac{x}{(n-1)+\dfrac{x}{(n-2)+\dfrac{\vdots}{\cdots+\dfrac{x}{1+x}}}}} f(x,n)=n+(n1)+(n2)++1+xxxxx

用递归函数求解。

输入格式

第一个数是 x x x 的值,第二个数是 n n n 的值。( x x x实数 n n n 为整数)

输出格式

函数值,保留两位小数。

样例 #1

样例输入 #1

1
2

样例输出 #1

0.40

提示说明

在这里插入图片描述

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;
double x;

inline double f(ll n)
{
    if(n==1) return x/(1+x);
    else return x/(n+f(n-1));
}

int main()
{
    ll n;
    cin>>x>>n;
    
    printf("%.2f",f(n));
    return 0;
}
  • 6
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值