人口增长问题

人口增长问题

题目描述

假设目前的世界人口有 x x x 亿,按照每年 0.1 % 0.1\% 0.1% 的增长速度, n n n 年后将有多少人?

输入格式

一行两个正整数 x x x n n n,之间有一个空格。其中, 1 ≤ x ≤ 100 , 1 ≤ n ≤ 100 1 \leq x\leq 100, 1\leq n\leq 100 1x100,1n100

输出格式

一行一个数,表示答案。以亿为单位,保留到小数点后 4 4 4 位。

样例 #1

样例输入 #1

13 10

样例输出 #1

13.1306

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    double x;
    ll n;
    cin>>x>>n;

    while(n--) x+=x*0.001;
    cout<<fixed<<setprecision(4)<<x<<endl;
    
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值