hi.验证子串

验证子串

题目描述

输入两个字符串,验证其中一个串是否为另一个串的子串。

输入格式

两行,每行一个字符串。

输出格式

若第一个串 s 1 s_1 s1 是第二个串 s 2 s_2 s2 的子串,则输出(s1) is substring of (s2)

否则,若第二个串 s 2 s_2 s2 是第一个串 s 1 s_1 s1 的子串,输出(s2) is substring of (s1)

否则,输出 No substring

样例 #1

样例输入 #1

abc
dddncabca

样例输出 #1

abc is substring of dddncabca

样例 #2

样例输入 #2

aaa
bbb

样例输出 #2

No substring

提示说明

对于 100 % 100 \% 100% 的数据,字符串长度在 20 20 20 以内。

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

int main()
{
    string a,b;
    cin>>a>>b;
    
    if(a.find(b)!=a.npos) //如果b是a的子串
        cout<<b<<" is substring of "<<a<<endl;
    else if(b.find(a)!=b.npos) //如果a是b的子串 
        cout<<a<<" is substring of "<<b<<endl;
    else //如果没有子串关系 
        cout<<"No substring"<<endl;
    
    return 0;
}
  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值