hi.密码翻译

密码翻译

题目背景

Update on 2023.01.21 11:33:00 \text{Update on 2023.01.21 11:33:00} Update on 2023.01.21 11:33:00:目前数据已经修复,对于题解中提到的 @ 应视作 A 的问题经调查发现为一个错误,现在已经修复。

题目描述

在情报传递过程中,为了防止情报被截获,往往需要对情报用一定的方式加密。我们给出一种最简单的加密方法,对给定的一个字符串,把其中从 a ∼ y \texttt{a} \sim \texttt{y} ay A ∼ Y \texttt{A} \sim \texttt{Y} AY 的字母用其后继字母替代,把 z \texttt{z} z Z \texttt{Z} Z a \texttt{a} a A \texttt{A} A 替代,其他非字母字符不变。请根据该加密规则将输入的密码进行解密。

提示:这里需要进行解密操作,而不是加密

输入格式

一行,加密后的字符串,长度不多于 10000 10000 10000 个字符。

输出格式

一行,将密码解密后的字符串。

样例 #1

样例输入 #1

Ifmmp !  Ipx  bsf  zpv!

样例输出 #1

Hello !  How  are  you!

提示说明

感谢 @Hughpig 提供本题数据。

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <sstream>//整型转字符串
// #include <stack>//栈
// #include <deque>//堆/优先队列
// #include <queue>//队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>
using namespace std;

typedef long long ll;

int main()
{
    string s;
    getline(cin,s);

    for(auto &t:s)
    {
        if(islower(t))
            cout<<char(((t-'a'-1+26)%26+'a'));
        else if(isupper(t))
            cout<<char(((t-'A'-1+26)%26+'A'));
        else cout<<t;
    }
    
    return 0;
}
  • 13
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值