Stones on the Table

Stones on the Table

题面翻译

题目描述

桌子上有N个石头,每一块都可以是红的、绿的或蓝的。计算从桌子上取下的石头的最小数量,以便任何两块相邻的石头都有不同的颜色。如果没有其他石头,一排石头被认为是相邻的。

输入输出格式

输入格式:
第一行是一个整数n(1<=n<=50)–桌上石头的数量

第二行是一个字符串s,代表着石头的颜色,石头的排法为从1到n,从左到右。s中的第i个字母如果是"R",那么第i个石头就是红色,"G"是绿色,"B"是蓝色

输出格式:
输出一个整数——这个问题的答案

感谢U91783提供的翻译

题目描述

There are $ n $ stones on the table in a row, each of them can be red, green or blue. Count the minimum number of stones to take from the table so that any two neighboring stones had different colors. Stones in a row are considered neighboring if there are no other stones between them.

输入格式

The first line contains integer $ n $ $ (1<=n<=50) $ — the number of stones on the table.

The next line contains string $ s $ , which represents the colors of the stones. We’ll consider the stones in the row numbered from $ 1 $ to $ n $ from left to right. Then the $ i $ -th character $ s $ equals “R”, if the $ i $ -th stone is red, “G”, if it’s green and “B”, if it’s blue.

输出格式

Print a single integer — the answer to the problem.

样例 #1

样例输入 #1

3
RRG

样例输出 #1

1

样例 #2

样例输入 #2

5
RRRRR

样例输出 #2

4

样例 #3

样例输入 #3

4
BRBG

样例输出 #3

0

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll n;
    string s;
    cin>>n>>s;

    ll op=0;
    for(ll i=0;i<s.size()-1;i++)
    {
        if(s[i]==s[i+1]) op++;
    }

    cout<<op<<endl;
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值