Soldier and Bananas

Soldier and Bananas

题面翻译

有个士兵想买 w w w 个香蕉,第 i i i 个香蕉需支付 k i ki ki 元。

现在他手里有 n n n 元,问他至少要借多少钱才能买到 w w w 个香蕉?(不需要借钱输出 0 0 0)。

输入一行三个整数 n n n, k k k, w w w, 含义如题面。

题目描述

A soldier wants to buy $ w $ bananas in the shop. He has to pay $ k $ dollars for the first banana, $ 2k $ dollars for the second one and so on (in other words, he has to pay $ i·k $ dollars for the $ i $ -th banana).

He has $ n $ dollars. How many dollars does he have to borrow from his friend soldier to buy $ w $ bananas?

输入格式

The first line contains three positive integers $ k,n,w $ ( $ 1<=k,w<=1000 $ , $ 0<=n<=10^{9} $ ), the cost of the first banana, initial number of dollars the soldier has and number of bananas he wants.

输出格式

Output one integer — the amount of dollars that the soldier must borrow from his friend. If he doesn’t have to borrow money, output $ 0 $ .

样例 #1

样例输入 #1

3 17 4

样例输出 #1

13

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll k,n,w;
    cin>>k>>n>>w;

    ll pay=(w+1)*w/2*k;

    if(n>=pay) cout<<0<<endl;
    else cout<<pay-n<<endl;
    
    return 0;
}



  • 30
    点赞
  • 21
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值