String Task

String Task

题面翻译

给出一个长度为 n n n 的单词,写出一个程序,执行以下操作:

  • 删除单词里的元音字母。
  • 辅音字母前加上字符 .
  • 所有大写字母全部转化为小写字母。

注:元音字母有 A,O,Y,E,U,I \text{A,O,Y,E,U,I} A,O,Y,E,U,I,其余的全部都是辅音字母。

输入仅一行,为一个单词(仅包含大小写字母)。
输出仅一行,代表经程序处理后的单词。

数据范围: 1 ⩽ n ⩽ 100 1\leqslant n\leqslant 100 1n100

题目描述

Petya started to attend programming lessons. On the first lesson his task was to write a simple program. The program was supposed to do the following: in the given string, consisting if uppercase and lowercase Latin letters, it:

  • deletes all the vowels,
  • inserts a character “.” before each consonant,
  • replaces all uppercase consonants with corresponding lowercase ones.

Vowels are letters “A”, “O”, “Y”, “E”, “U”, “I”, and the rest are consonants. The program’s input is exactly one string, it should return the output as a single string, resulting after the program’s processing the initial string.

Help Petya cope with this easy task.

输入格式

The first line represents input string of Petya’s program. This string only consists of uppercase and lowercase Latin letters and its length is from $ 1 $ to $ 100 $ , inclusive.

输出格式

Print the resulting string. It is guaranteed that this string is not empty.

样例 #1

样例输入 #1

tour

样例输出 #1

.t.r

样例 #2

样例输入 #2

Codeforces

样例输出 #2

.c.d.f.r.c.s

样例 #3

样例输入 #3

aBAcAba

样例输出 #3

.b.c.b

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    string s;
    cin>>s;

    for(auto &t:s)
    {
        if(isupper(t)) t+=32;
    }

    for(auto &t :s)
    {
        if(t=='a'||t=='o'||t=='y'||t=='e'||t=='u'||t=='i')
            continue;
        cout<<"."<<t;
    }
    
    return 0;
}



  • 31
    点赞
  • 20
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值