Vanya and Fence

Vanya and Fence

题面翻译

有n个人,如果这个人的高度大于k,那么马路宽度+2,否则+1,输出最终的宽度值。

输入格式:
第一行是n和k
第二行是n个数(这个人的高度)
输出格式:
输出最终的宽度值。

感谢@666yuchen 提供的翻译和@王轶凡lg2018 提供的建议

题目描述

Vanya and his friends are walking along the fence of height $ h $ and they do not want the guard to notice them. In order to achieve this the height of each of the friends should not exceed $ h $ . If the height of some person is greater than $ h $ he can bend down and then he surely won’t be noticed by the guard. The height of the $ i $ -th person is equal to $ a_{i} $ .

Consider the width of the person walking as usual to be equal to $ 1 $ , while the width of the bent person is equal to $ 2 $ . Friends want to talk to each other while walking, so they would like to walk in a single row. What is the minimum width of the road, such that friends can walk in a row and remain unattended by the guard?

输入格式

The first line of the input contains two integers $ n $ and $ h $ ( $ 1<=n<=1000 $ , $ 1<=h<=1000 $ ) — the number of friends and the height of the fence, respectively.

The second line contains $ n $ integers $ a_{i} $ ( $ 1<=a_{i}<=2h $ ), the $ i $ -th of them is equal to the height of the $ i $ -th person.

输出格式

Print a single integer — the minimum possible valid width of the road.

样例 #1

样例输入 #1

3 7
4 5 14

样例输出 #1

4

样例 #2

样例输入 #2

6 1
1 1 1 1 1 1

样例输出 #2

6

样例 #3

样例输入 #3

6 5
7 6 8 9 10 5

样例输出 #3

11

提示说明

In the first sample, only person number $ 3 $ must bend down, so the required width is equal to $ 1+1+2=4 $ .

In the second sample, all friends are short enough and no one has to bend, so the width $ 1+1+1+1+1+1=6 $ is enough.

In the third sample, all the persons have to bend, except the last one. The required minimum width of the road is equal to $ 2+2+2+2+2+1=11 $ .

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll n,k;
    cin>>n>>k;

    ll ans=n;
    while(n--)
    {
        ll x;
        cin>>x;
        if(x>k) ans++;
    }

    cout<<ans<<endl;
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值