In Search of an Easy Problem

In Search of an Easy Problem

题面翻译

给出一个01串,如果全0则输出EASY,否则输出HARD。

题目描述

When preparing a tournament, Codeforces coordinators try treir best to make the first problem as easy as possible. This time the coordinator had chosen some problem and asked $ n $ people about their opinions. Each person answered whether this problem is easy or hard.

If at least one of these $ n $ people has answered that the problem is hard, the coordinator decides to change the problem. For the given responses, check if the problem is easy enough.

输入格式

The first line contains a single integer $ n $ ( $ 1 \le n \le 100 $ ) — the number of people who were asked to give their opinions.

The second line contains $ n $ integers, each integer is either $ 0 $ or $ 1 $ . If $ i $ -th integer is $ 0 $ , then $ i $ -th person thinks that the problem is easy; if it is $ 1 $ , then $ i $ -th person thinks that the problem is hard.

输出格式

Print one word: “EASY” if the problem is easy according to all responses, or “HARD” if there is at least one person who thinks the problem is hard.

You may print every letter in any register: “EASY”, “easy”, “EaSY” and “eAsY” all will be processed correctly.

样例 #1

样例输入 #1

3
0 0 1

样例输出 #1

HARD

样例 #2

样例输入 #2

1
0

样例输出 #2

EASY

提示说明

In the first example the third person says it’s a hard problem, so it should be replaced.

In the second example the problem easy for the only person, so it doesn’t have to be replaced.

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll n,s=0;
    cin>>n;
    
    for(ll i=1;i<=n;i++)
    {
        ll c;
        cin>>c;
        s+=c;
    }
    
    if(!s) cout<<"EASY"<<endl;
    else cout<<"HARD"<<endl;
    
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值