George and Accommodation

George and Accommodation

题面翻译

一共有 n 间房间(1<=n<=100),第 i 个房间里有 pi 个人,第 i 个房间内总共可以住 qi 个人。

给定 n 和对应的 pi、qi ,问有几个房间至少还有2个空位。

题目描述

George has recently entered the BSUCP (Berland State University for Cool Programmers). George has a friend Alex who has also entered the university. Now they are moving into a dormitory.

George and Alex want to live in the same room. The dormitory has $ n $ rooms in total. At the moment the $ i $ -th room has $ p_{i} $ people living in it and the room can accommodate $ q_{i} $ people in total ( $ p_{i}<=q_{i} $ ). Your task is to count how many rooms has free place for both George and Alex.

输入格式

The first line contains a single integer $ n $ $ (1<=n<=100) $ — the number of rooms.

The $ i $ -th of the next $ n $ lines contains two integers $ p_{i} $ and $ q_{i} $ $ (0<=p_{i}<=q_{i}<=100) $ — the number of people who already live in the $ i $ -th room and the room’s capacity.

输出格式

Print a single integer — the number of rooms where George and Alex can move in.

样例 #1

样例输入 #1

3
1 1
2 2
3 3

样例输出 #1

0

样例 #2

样例输入 #2

3
1 10
0 10
10 10

样例输出 #2

2

代码内容

// #include <iostream>
// #include <algorithm>
// #include <cstring>
// #include <stack>//栈
// #include <deque>//队列
// #include <queue>//堆/优先队列
// #include <map>//映射
// #include <unordered_map>//哈希表
// #include <vector>//容器,存数组的数,表数组的长度
#include <bits/stdc++.h>

using namespace std;

typedef long long ll;

int main()
{
    ll n;
    cin>>n;

    ll ans=0;
    while(n--)
    {
        ll p,q;
        cin>>p>>q;
        if(q-p>=2) ans++;
    }

    cout<<ans<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Pretty Boy Fox

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值