POJ-1611-The Suspects

The Suspects

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

题目大意:

给定学生数量n和团队数量m,编号0代表患SARS的学生,他会将自己团队的其他学生全部传染。问最后患SARS学生的数量。

思路:

套用并查集模板,需要开一个数组记录每个人做团队BOSS时所在团队的人数,初始化每个元素值为1。最后找出0号同学所在团队有多少人
代码如下:

#include<iostream>
using namespace std;
int student[30010],num[30010];
int father(int a)
{
  if(student[a]==a)return a;
  else return student[a]=father(student[a]);
}
void merge(int a,int b)
{
  int ta=father(a),tb=father(b);
  if(ta!=tb)
  {
    student[tb]=ta;
    num[ta]+=num[tb];
  }
}
void init(int n)
{
  for(int i=0;i<n;i++){student[i]=i;num[i]=1;}
}
int main()
{
  int n,m;
  while(cin>>n>>m&&(n||m))
  {
    init(n);
    int b[31010]={0};
    for(int i=0;i<m;i++)
    {
      int t;
      cin>>t;
      for(int j=0;j<t;j++)cin>>b[j];
      for(int j=0;j<t-1;j++)merge(b[j],b[j+1]);
    }
    int k1=father(0);
    cout<<num[k1]<<endl;
  }
}

需要注意的是最后找的是0号同学所在团队的最高领导人,而不是0号同学的领导人(注意是最高),故而是

k1=father(0),而不是student(0);

这个地方害我WA了好几次。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值