hdu 1143 Tri Tiling

Tri Tiling

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2112    Accepted Submission(s): 1206


Problem Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes? Here is a sample tiling of a 3x12 rectangle.


 

Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 ≤ n ≤ 30.
 

Output
For each test case, output one integer number giving the number of possible tilings.
 

Sample Input
  
  
2 8 12 -1
 

Sample Output
  
  
3 153 2131
 
总结:
代码比较简单易懂,但是我们要注重递推过程,根据自己动手动脑推出递推公式。

递推:
<span style="font-size:18px;">#include<stdio.h>
int main ()
{
 int n,i;
 int a[40];
 while(~scanf("%d",&n)&&n!=-1)
 {
  a[0]=1; // 为什么是1???
  a[1]=0;
  a[2]=3;
  a[3]=0;
  a[4]=11;
  for(i=5;i<=31;i++)
  {
   if(i%2==0)
	   a[i]=a[i-2]*4-a[i-4];
   else 
	   a[i]=0;
  }
  printf("%d\n",a[n]);
 }
}</span>


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值