HDU 1728 逃离迷宫

135 篇文章 0 订阅
32 篇文章 0 订阅
给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
 

Input
  第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,   第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x[sub]1[/sub], y[sub]1[/sub], x[sub]2[/sub], y[sub]2[/sub] (1 ≤ k ≤ 10, 1 ≤ x[sub]1[/sub], x[sub]2[/sub] ≤ n, 1 ≤ y[sub]1[/sub], y[sub]2[/sub] ≤ m),其中k表示gloria最多能转的弯数,(x[sub]1[/sub], y[sub]1[/sub]), (x[sub]2[/sub], y[sub]2[/sub])表示两个位置,其中x[sub]1[/sub],x[sub]2[/sub]对应列,y[sub]1[/sub], y[sub]2[/sub]对应行。
 

Output
  每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
 

Sample Input
  
  
2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
 

Sample Output
  
  
no yes
在搜索中加个WHILE 让他向一边走到低就行了
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <queue>
using namespace std;
char map[105][105];
int use[105][105],x1,y1,x2,y2,T;
int i,n,m;
int d[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
struct kk
{
    int x,y,t;
};
bool pd(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    if(map[x][y]=='*')
        return false;
    return true;
}

bool bfs()
{
    queue<kk> q;
    kk now,next;
    now.x=x1,now.y=y1,now.t=-1;
    use[x1][y1]=0;
    q.push(now);
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.t>=T) continue;
        for(i=0;i<4;i++)
        {
            next.x=now.x+d[i][0];
            next.y=now.y+d[i][1];
            next.t=now.t+1;
            while(1)
            {
                if(!pd(next.x,next.y))
                    break;
                if(next.x==x2&&next.y==y2)
                    return true;
                if(use[next.x][next.y])
                {
                    q.push(next);
                    use[next.x][next.y]=0;
                }
                next.x+=d[i][0];
                next.y+=d[i][1];
            }
        }
    }
    return false;
}
int main()
{
    int cas;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d %d",&n,&m);
        for(i=0;i<n;i++)
            cin>>map[i];
        memset(use,1,sizeof use);
        scanf("%d %d %d %d %d",&T,&y1,&x1,&y2,&x2);
        x1--,x2--;y1--,y2--;
        if(bfs())
            printf("yes\n");
        else printf("no\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值