HDU 4229 Vive la Difference!

135 篇文章 0 订阅
50 篇文章 0 订阅

Take any four positive integers: a, b, c, d. Form four more, like this:
|a-b| |b-c| |c-d| |d-a|

That is, take the absolute value of the differences of a with b, b with c, c with d, and d with a. (Note that a zero could crop up, but they’ll all still be non-negative.) Then, do it again with these four new numbers. And then again. And again. Eventually, all four integers will be the same. For example, start with 1,3,5,9:
1 3 5 9
2 2 4 8 (1)
0 2 4 6 (2)
2 2 2 6 (3)
0 0 4 4 (4)
0 4 0 4 (5)
4 4 4 4 (6)
In this case, the sequence converged in 6 steps. It turns out that in all cases, the sequence converges very quickly. In fact, it can be shown that if all four integers are less than 2^n, then it will take no more than 3*n steps to converge!
Given a, b, c and d, figure out just how quickly the sequence converges.
 

Input

There will be several test cases in the input. Each test case consists of four positive integers on a single line (1 ≤ a,b,c,d ≤ 2,000,000,000), with single spaces for separation. The input will end with a line with four 0s.
 

Output

For each test case, output a single integer on its own line, indicating the number of steps until convergence. Output no extra spaces, and do not separate answers with blank lines.
 

Sample Input

    
    
1 3 5 9 4 3 2 1 1 1 1 1 0 0 0 0
 

Sample Output

    
    
6 4 0

#include <stdio.h>


int pd(long long a,long long b,long long c,long long d)
{
    if(a==b&&a==c&&a==d)
        return 1;
    return 0;
}
long long f(long long n)
{
    return n>0?n:-n;
}
int main()
{
    long long a,b,c,d,e;
    int i;
    while(~scanf("%lld %lld %lld %lld",&a,&b,&c,&d),a||b||c||d)
    {
        for(i=0;;i++)
        {
            if(pd(a,b,c,d))
                break;
            e=a;
            a=f(a-b),b=f(b-c),c=f(c-d),d=f(d-e);
        }
        printf("%d\n",i);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值