NBUT 1220 SPY

135 篇文章 0 订阅
50 篇文章 0 订阅

The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?

A:the list contains that will come to the NationX’s frontier.

B:the list contains spies that will be sent by Nation Y.

C:the list contains spies that were sent to NationY before.

Input

There are several test cases.
Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before.
The second part contains A strings, the name list of that will come into the frontier.
The second part contains B strings, the name list of that are sent by NationY.
The second part contains C strings, the name list of the “dual_spy”.
There will be a blank line after each test case.
There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.

Output

Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”.

Sample Input

8 4 3
Zhao Qian Sun Li Zhou Wu Zheng Wang
Zhao Qian Sun Li
Zhao Zhou Zheng
2 2 2
Zhao Qian
Zhao Qian
Zhao Qian

Sample Output

Qian Sun Li
No enemy spy

找间蝶  第二串是有嫌疑 第一串是全部的人 如果在第一串中出现过且在第三串中没出现 那就是间谍


#include <stdio.h>
#include <string.h>

char ans[10000][40];
char a[10000][40],b[10000][40],c[10000][40];
int main()
{
	int k1,k2,k3,i,j,k,flag;
	
	while(~scanf("%d %d %d",&k1,&k2,&k3))
	{
		for(i=0;i<k1;i++)
			scanf("%s",a[i]);
		for(i=0;i<k2;i++)
			scanf("%s",b[i]);
		for(i=0;i<k3;i++)
			scanf("%s",c[i]);
		k=0;
		for(i=0;i<k2;i++)
		{
			for(j=0;j<k1;j++)
			{
				if(strcmp(b[i],a[j])==0)
				{
					strcpy(ans[k++],b[i]);
					break;
				}
			}
		}
		flag=1;
		if(k==0)
			printf("No enemy spy\n");
		else
		{
			for(i=0;i<k;i++)
			{
				for(j=0;j<k3;j++)
				{
					if(strcmp(ans[i],c[j])==0)
					{
						break;
					}
				}

				if(j==k3)
				{
					if(flag)
					{
						flag=0;
						printf("%s",ans[i]);
					}
					else printf(" %s",ans[i]);
				}
			}
			if(flag)
		{
			printf("No enemy spy\n");
		}
		else printf("\n");
		}
		
	}	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值