hdu 3555 Bomb

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input

3
1
50
500

Sample Output

0
1
15
题目大概意思是:求1~N中含49的数,这题和2089是一个类型的题。但是注意的对于N+1处理。我求的是(0,n)的数,题目求的是【1,N】的数,然后去掉0.

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
using namespace std;
long long  dp[25][20];//此处要用 longlong 
int d[25];

long long num(long long  nn)
{
    int len=0;
    long long ans=0;
    while(nn)
    {
        d[++len]=nn%10;
        nn/=10;
     } 
     d[++len]=0;
     for(int i=len;i>=1;i--)
     {
        for(int j=0;j<d[i];j++)
        {
            if(d[i+1]!=4||j!=9)
            ans+=dp[i][j];
         }
         if(d[i]==9&&d[i+1]==4)
            break;
     }
     return ans;
}

int main()
{
    int t;
    cin>>t;
    long long   n,x;
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1;i<=20;i++)//i位数 
    for(int j=0;j<10;j++)//最高位 
    for(int k=0;k<10;k++)//第2高位 
    if(j!=4||k!=9)      //j=4,k=9不同时成立 
    dp[i][j]+=dp[i-1][k];
    while(t--)
    {
        cin>>n;
        x=num(n+1);//不要49的数 
        cout<<n+1-x<<endl;
    }
    return 0;
 } 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值