2010年辽宁省赛 NBUT 1218【DFS实现树的遍历与更新】

  • [1218] You are my brother

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 链接:NBUT 1218
  • 问题描述
  • Little A gets to know a new friend, Little B, recently. One day, they realize that they are family 500 years ago. Now, Little A wants to know whether Little B is his elder, younger or brother.
  • 输入
  • There are multiple test cases.
    For each test case, the first line has a single integer, n (n<=1000). The next n lines have two integers a and b (1<=a,b<=2000) each, indicating b is the father of a. One person has exactly one father, of course. Little A is numbered 1 and Little B is numbered 2.
    Proceed to the end of file.
  • 输出
  • For each test case, if Little B is Little A’s younger, print “You are my younger”. Otherwise, if Little B is Little A’s elder, print “You are my elder”. Otherwise, print “You are my brother”. The output for each test case occupied exactly one line.
  • 样例输入
  • 5
    1 3
    2 4
    3 5
    4 6
    5 6
    6
    1 3
    2 4
    3 5
    4 6
    5 7
    6 7
    
  • 样例输出
  • You are my elder
    You are my brother

题意:

给定N次输入,每次输入一行ab,表示ba的父亲。最后求节点1与节点2的关系【即比较深度】 

N<=10001<=a,b<=2000

分析:

题意很明确,对于每个节点我都用一个值Rank保存该节点的深度,所以每次把节点a为根节点的树合并到节点b为根节点的树上面的时候,我要把从节点a以及节点a以下的节点全部的Rank值都加上节点bRank值。就这样,一个结构体保存着每个节点的信息,每次合并两棵树的时候DFS更新这些节点就OK了。

代码实现:

#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define FIN             freopen("input.txt","r",stdin)
struct Node
{
    int Rank;
    vector<int> Son;
} Nodes[2000 + 5];
void dfs(int pos, const int& val)
{
    Nodes[pos].Rank += val;
    int num = Nodes[pos].Son.size();
    if(num == 0) return;
    for(int i = 0; i < num; i++)
    {
        int &np = Nodes[pos].Son[i];
        dfs(np, val);
    }
}
void init()
{
    for(int i = 1; i <= 2000; i++)
    {
        Nodes[i].Rank = 1;
        Nodes[i].Son.clear();
    }
}
int main()
{
//    FIN;
    int n, a, b;
    while(~scanf("%d", &n))
    {
        init();
        for(int i = 1; i <= n; i++)
        {
            scanf("%d%d", &a, &b);
            Nodes[b].Son.push_back(a);
            dfs(a, Nodes[b].Rank);
        }
        if(Nodes[1].Rank == Nodes[2].Rank)
            printf("You are my brother\n");
        else if(Nodes[1].Rank > Nodes[2].Rank)
            printf("You are my elder\n");
        else
            printf("You are my younger\n");

    }
    return 0;
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值