POJ 2240 Arbitrage Bellman_ford

F - Arbitrage

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

/*
     题目大意,先给出所有的货币种类n种,然后给出m个货币的交换汇率,然后问有没有一种方式可以套汇,即用一定量的A货币经过两次或多次兑换后大于A货币的起始数目。

     本题目和利用Bellman_Ford算法判断负权边思路 差不多,大意是找乘积大于1的环是否存在。
*/ 

AC code:

#include <iostream>
#include <algorithm>
#include <string>
#include <cstring>
#include <queue>
#include <stack>
#include <cmath>
#include <vector>
#include <cstdio>
#define MAX 1010
const int INF = 0x3f3f3f3f;

using namespace std;

char tr[1010][30];
struct node
{
    int x,y;
    double w;
}ans[MAX];
double dis[MAX];

bool B_F(int v,int n,int m)
{
    memset(dis,0,sizeof(dis));
    dis[v] = 1;
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(dis[ans[j].x]*ans[j].w > dis[ans[j].y])
            {
                dis[ans[j].y] = dis[ans[j].x]*ans[j].w;
            }
        }
    }
    if(dis[v] > 1.0)
        return true;
    else
        return false;
}
int main()
{
    int n,m,t = 1;
    bool flag;double c;
    while(~scanf("%d",&n) && n)
    {
        for(int i=0;i<n;i++)
            scanf("%s",tr[i]);
        scanf("%d",&m);
        char a[30],b[30];
        for(int i=0,j,k;i<m;i++)
        {
            scanf("%s %lf %s",a,&c,b);
            for(j=0;strcmp(a,tr[j]);j++);
            for(k=0;strcmp(b,tr[k]);k++);
            ans[i].x=j;ans[i].y=k;ans[i].w=c;
        }
        flag = false;
        for(int i=0;i<n;i++)
        {
            if(B_F(i,n,m))
            {
                flag = true;break;
            }
        }
        if(flag)
            cout<<"Case "<<t++<<": Yes"<<endl;
        else
            cout<<"Case "<<t++<<": No"<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值