Pots
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13265 Accepted: 5572 Special Judge
Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:
FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.
Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).
Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.
Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)
Source
Northeastern Europe 2002, Western Subregion
BFS 用struct的*pre输出路径
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
#include<vector>
using namespace std;
int n,m,en;
int vis[102][102];int ans,anss;int flag=0;
char str[6][10]={"FILL(1)", "DROP(1)", "POUR(1,2)", "FILL(2)", "DROP(2)", "POUR(2,1)"};
struct node{
int x,y,id;
node(int xx,int yy,int idd)
{
x=xx,y=yy;
id=idd;
} node(){}
};
queue<node> q;
int a[100002];
struct nod{
int pre;int k;
}an[100002];
void bfs()
{
int tot=0;
q.push(node(0,0,++tot));
vis[0][0]=1;
while(!q.empty()&&flag==0)
{
node now=q.front();
//cout<<now.x<<" "<<now.y<<" "<<vis[now.x][now.y]<<endl;
q.pop();
for(int i=1;i<=6;i++)
{
int nx,ny;
if(flag==1) break;
if(i==1)
{
nx=n;
ny=now.y;
}
else if(i==2)
{
nx=0;
ny=now.y;
}
else if(i==3)
{
nx=now.x-(m-now.y);
ny=m;
if(nx<0)
{
ny+=nx;
nx=0;
}
}
else if(i==4)
{
nx=now.x;
ny=m;
}
else if(i==5)
{
nx=now.x;
ny=0;
}
else if(i==6)
{
ny=now.y-(n-now.x);
nx=n;
if(ny<0)
{
nx+=ny;
ny=0;
}
}
if(!vis[nx][ny])
{
vis[nx][ny]=vis[now.x][now.y]+1;
if(nx==en||ny==en)
{
//cout<<" "<<i<<" "<<tot<<endl;
ans=vis[now.x][now.y];
anss=tot+1;
flag=1;
}
q.push(node(nx,ny,++tot));
an[tot].pre=now.id,an[tot].k=i;
//if(tot==13) cout<<an[14].k<<endl;
}
}
}
}
void pp()
{
if(flag==0)
printf("impossible\n");
else
{
printf("%d\n",ans);
int ansss=ans;
while(ansss)
{
//cout<<" "<<ansss<<" "<<an[anss].k<<endl;
a[ansss]=an[anss].k;
//cout<<" "<<a[ansss]<<" "<<ansss<<endl;
anss=an[anss].pre;
ansss--;
}
for(int i=1;i<=ans;i++)
printf("%s\n",str[a[i]-1]);
}
}
int main()
{
scanf("%d%d%d",&n,&m,&en);
bfs();
pp();
}