Card Game Cheater HDU - 1528


点击打开链接

                           Card Game Cheater

  HDU - 1528 
Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):  


If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.  


If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.  


A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.  


If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.  

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs.  

This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.  

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.  

Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.  

Each test case starts with a line with a single positive integer k <= 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line  

TC 2H JD  
Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.  

Sample Input
3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D
Sample Output
1
1
2

题意:总共有52张牌,牌的大小关系为1~9TJQKA;从小到大顺序,每张牌有两个字母,一个是大小,一个是优先级,大小相等的,优先级高的大,H>S>D>C,,第一行为对方出牌的大小和顺序。那么你最多可以赢对方几次?

思路:和田忌赛马一样,使用最大匹配就行了、这是一个模板题,上面是AC代码。

#include <stdio.h>
#include <string.h>

int map[210][210];
int math[210];
int book[210];
int n,m;

struct node
{
    int x;
    int k;
} Q[410];

int F(char s)
{
    if(s>='2'&&s<='9')
        return s-'0';
    if(s=='T')
        return 10;
    if(s=='J')
        return 11;
    if(s=='Q')
        return 12;
    if(s=='K')
        return 13;
    if(s=='A')
        return 14;
    if(s=='H')
        return 4;
    if(s=='S')
        return 3;
    if(s=='D')
        return 2;
    if(s=='C')
        return 1;

}

int  dfs(int x)
{

    for(int i=1; i<=2*n; i++)
    {
        if(!book[i]&&map[x][i])
        {
            book[i]=1;
            if(!math[i]||dfs(math[i]))
            {
                math[i]=x;
                math[x]=i;
                return 1;
            }
        }
    }
    return 0;
}

void F()
{
    int sum=0;
    memset(math,0,sizeof(math));
    for(int i=n+1; i<=2*n; i++)
    {
        memset(book,0,sizeof(book));
        if(dfs(i))
        {
            /*for(int i=1; i<=2*n; i++)
                printf("%d ",math[i]);
            printf("\n");*/
            sum++;
        }

    }
    printf("%d\n",sum);
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        char str[100];
        scanf("%d",&n);

        for(int j=1; j<=n*2; j++)
        {
            scanf("%s",str);
            Q[j].x=F(str[0]);
            Q[j].k=F(str[1]);
        }

        memset(map,0,sizeof(map));

        for(int i=n+1; i<=2*n; i++)
            for(int j=1; j<=n; j++)
                if(Q[i].x>Q[j].x||Q[i].x==Q[j].x&&Q[i].k>Q[j].k)
                    map[i][j]=1;
        F();
    }
    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值